]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sci-mathematics/dunshire/dunshire-0.1.1.ebuild
New package: sci-mathematics/dunshire.
[mjo-overlay.git] / sci-mathematics / dunshire / dunshire-0.1.1.ebuild
diff --git a/sci-mathematics/dunshire/dunshire-0.1.1.ebuild b/sci-mathematics/dunshire/dunshire-0.1.1.ebuild
new file mode 100644 (file)
index 0000000..78aa75d
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to solve linear games over symmetric cones"
+HOMEPAGE="http://michael.orlitzky.com/code/${PN}"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+       use doc && local HTML_DOCS=( doc/build/html/. )
+       local DOCS=( doc/README.rst )
+       distutils-r1_python_install_all
+}
+
+python_test() {
+       esetup.py test
+}