]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - sci-mathematics/dunshire/dunshire-0.1.1.ebuild
78aa75d3354436b01b17548c7e1273583841d6ae
[mjo-overlay.git] / sci-mathematics / dunshire / dunshire-0.1.1.ebuild
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=6
6
7 PYTHON_COMPAT=( python3_{4,5} )
8
9 inherit distutils-r1
10
11 DESCRIPTION="Python library to solve linear games over symmetric cones"
12 HOMEPAGE="http://michael.orlitzky.com/code/${PN}"
13 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc test"
19
20 RDEPEND="dev-python/cvxopt[${PYTHON_USEDEP}]"
21 DEPEND="${RDEPEND}
22 dev-python/setuptools[${PYTHON_USEDEP}]"
23
24 python_install_all() {
25 use doc && local HTML_DOCS=( doc/build/html/. )
26 local DOCS=( doc/README.rst )
27 distutils-r1_python_install_all
28 }
29
30 python_test() {
31 esetup.py test
32 }