]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild
Add the libexecdir fix posted by Samuli.
[mjo-overlay.git] / xfce-extra / xfce4-hdaps / xfce4-hdaps-0.0.7.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild,v 1.4 2011/05/20 11:21:23 tomka Exp $
4
5 EAPI=4
6 inherit linux-info xfconf
7
8 DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
9 HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.php"
10 SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
11
12 LICENSE="GPL-3"
13 SLOT="0"
14 KEYWORDS="amd64 x86"
15 IUSE="debug"
16
17 COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
18 >=xfce-base/libxfce4ui-4.8
19 >=xfce-base/libxfce4util-4.8
20 >=xfce-base/xfce4-panel-4.8"
21 RDEPEND="${COMMON_DEPEND}
22 >=app-laptop/hdapsd-20081213
23 >=app-laptop/tp_smapi-0.39"
24 DEPEND="${COMMON_DEPEND}
25 dev-util/pkgconfig
26 dev-util/intltool
27 sys-devel/gettext"
28
29 pkg_setup() {
30 XFCONF=(
31 --disable-option-checking
32 --libexecdir="${EPREFIX}"/usr/$(get_libdir)
33 $(xfconf_use_debug)
34 )
35
36 DOCS=( AUTHORS ChangeLog NEWS README TODO )
37
38 linux-info_pkg_setup
39
40 if kernel_is lt 2 6 28; then
41 echo
42 ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
43 echo
44 fi
45 }