]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild
www-apache/mod_ldap_user: put back the depend.apache stuff.
[mjo-overlay.git] / www-apache / mod_ldap_userdir / mod_ldap_userdir-1.1.19.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit apache-module depend.apache
8
9 DESCRIPTION="Look up Apache ~user directories in an LDAP directory"
10 HOMEPAGE="http://horde.net/~jwm/software/${PN}/"
11 SRC_URI="http://horde.net/~jwm/software/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE="ssl"
17
18 DEPEND="net-nds/openldap
19 ssl? ( dev-libs/openssl )"
20
21 # The module will compile fine without apache[ldap], but Apache will
22 # crash if you try to load ${PN} without mod_ldap loaded. The funny-
23 # looking atom was taken from depend.apache.eclass (need_apache2).
24 RDEPEND="${DEPEND}
25 =www-servers/apache-2*[ldap]"
26
27 APACHE2_MOD_CONF="47_${PN}"
28 APACHE2_MOD_DEFINE="LDAP LDAP_USERDIR"
29
30 DOCFILES="DIRECTIVES README user-ldif"
31
32 # Don't try to get away without this, even though it causes some deps to
33 # be repeated.
34 need_apache2