]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - www-apache/mod_backtrace/mod_backtrace-2.01.ebuild
www-apache/mod_whatkilledus: update description and inherits.
[mjo-overlay.git] / www-apache / mod_backtrace / mod_backtrace-2.01.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit apache-module depend.apache
8
9 DESCRIPTION="Debug segmentation faults in Apache threads"
10 HOMEPAGE="http://emptyhammock.com/projects/httpd/diag/"
11 SRC_URI="http://emptyhammock.com/downloads/wku_bt-${PV}.zip"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="unwind"
17
18 RDEPEND="=www-servers/apache-2*[debug]
19 unwind? ( sys-libs/libunwind )"
20 DEPEND="${RDEPEND}
21 app-arch/unzip"
22
23 APACHE2_MOD_CONF="10_${PN}"
24 APACHE2_MOD_DEFINE="BACKTRACE"
25
26 need_apache2
27
28 S="${WORKDIR}/wku_bt-${PV}"
29
30 src_compile() {
31 APXS2_ARGS="-c ${PN}.c diag.c -ldl"
32 if use unwind; then
33 APXS2_ARGS+=" -lunwind -DDIAG_HAVE_LIBUNWIND_BACKTRACE=1"
34 fi
35 apache-module_src_compile
36 }