]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - net-proxy/torsocks/torsocks-2.0.0.ebuild
net-proxy/torsocks: add gentoo package.
[mjo-overlay.git] / net-proxy / torsocks / torsocks-2.0.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-2.0.0.ebuild,v 1.1 2014/12/21 21:34:58 mrueg Exp $
4
5 EAPI=5
6
7 inherit autotools eutils multilib versionator
8
9 MY_PV="$(replace_version_separator 3 -)"
10 MY_PF="${PN}-${MY_PV}"
11 S=${WORKDIR}/${MY_PF}
12
13 DESCRIPTION="Use most socks-friendly applications with Tor"
14 HOMEPAGE="http://github.com/dgoulet/torsocks"
15 SRC_URI="https://github.com/dgoulet/torsocks/archive/v${MY_PV}.tar.gz -> ${MY_PF}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~arm ~x86"
20 IUSE="static-libs"
21
22 # We do not depend on tor which might be running on a different box
23 DEPEND=""
24 RDEPEND="${DEPEND}"
25
26 src_prepare() {
27 sed -i -e "/dist_doc_DATA/s/^/#/" Makefile.am doc/Makefile.am || die
28 eautoreconf
29 }
30
31 src_configure() {
32 econf $(use_enable static-libs static)
33 }
34
35 src_install() {
36 default
37
38 dodoc ChangeLog README.md TODO doc/notes/DEBUG doc/socks/{SOCKS5,socks-extensions.txt}
39
40 #Remove libtool .la files
41 cd "${D}"/usr/$(get_libdir)/torsocks
42 rm -f *.la
43 }