]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - net-dns/rbldnsd/rbldnsd-0.997a.ebuild
Add missing PYTHON_REQUIRED_USE.
[mjo-overlay.git] / net-dns / rbldnsd / rbldnsd-0.997a.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6 PYTHON_COMPAT=( python{2_6,2_7} )
7
8 inherit eutils toolchain-funcs user python-single-r1
9
10 DESCRIPTION="DNS server designed to serve blacklist zones"
11 HOMEPAGE="http://www.corpit.ru/mjt/rbldnsd.html"
12 SRC_URI="http://www.corpit.ru/mjt/rbldnsd/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~hppa ~sparc ~x86 ~x86-fbsd"
17 IUSE="ipv6 test zlib"
18
19 REQUIRED_USE="test? ( ${PYTHON_REQUIRED_USE} )"
20
21 RDEPEND="zlib? ( sys-libs/zlib )"
22 DEPEND="${RDEPEND}
23 test? ( ${PYTHON_DEPS}
24 dev-python/pydns:2[${PYTHON_USEDEP}] )"
25
26 src_prepare() {
27 epatch "${FILESDIR}/${P}-robust-ipv6-test-support.patch"
28 }
29
30 src_configure() {
31 # The ./configure file is handwritten and doesn't support a `make
32 # install` target, so there are no --prefix options. The econf
33 # function appends those automatically, so we can't use it.
34 ./configure \
35 $(use_enable ipv6) \
36 $(use_enable zlib) \
37 || die "./configure failed"
38 }
39
40 src_compile() {
41 emake \
42 AR="$(tc-getAR)" \
43 CC="$(tc-getCC)" \
44 RANLIB="$(tc-getRANLIB)"
45 }
46
47 src_test() {
48 emake check \
49 CC="$(tc-getCC)" \
50 PYTHON="${PYTHON}"
51 }
52
53 src_install() {
54 dosbin rbldnsd
55 doman rbldnsd.8
56 keepdir /var/db/rbldnsd
57 dodoc CHANGES* TODO NEWS README*
58 newinitd "${FILESDIR}"/initd-${PV} rbldnsd
59 newconfd "${FILESDIR}"/confd-${PV} rbldnsd
60 }
61
62 pkg_postinst() {
63 enewgroup rbldns
64 enewuser rbldns -1 -1 /var/db/rbldnsd rbldns
65 chown rbldns:rbldns /var/db/rbldnsd
66 }