]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.0.ebuild
Add net-analyzer/nagios-check_rbl-1.3.0.
[mjo-overlay.git] / net-analyzer / nagios-check_rbl / nagios-check_rbl-1.3.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit multilib
8
9 DESCRIPTION="check_rbl is a Nagios plugin that fails if a host is blacklisted"
10 HOMEPAGE="https://svn.id.ethz.ch/projects/nagios_plugins/wiki/check_rbl"
11
12 MY_P="${P/nagios-/}"
13
14 SRC_URI="https://svn.id.ethz.ch/projects/nagios_plugins/downloads/${MY_P}.tar.gz"
15 LICENSE="GPL-2"
16 SLOT="0"
17
18 KEYWORDS="~x86 ~amd64"
19 IUSE=""
20
21 # The Makefile.PL looks for Nagios::Plugin::Getopt and
22 # Nagios::Plugin::Threshold, but I believe these are provided by
23 # dev-perl/Nagios-Plugins.
24 RDEPEND="dev-lang/perl
25 dev-perl/Nagios-Plugin
26 dev-perl/Net-DNS
27 dev-perl/Readonly"
28 DEPEND="${RDEPEND}
29 virtual/perl-ExtUtils-MakeMaker"
30
31 S="${WORKDIR}/${MY_P}"
32
33 src_configure() {
34 local dest="/usr/$(get_libdir)/nagios/plugins"
35 perl Makefile.PL INSTALLSCRIPT="${dest}"
36 }