]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - app-text/XML-Schema-learner/XML-Schema-learner-9999.ebuild
Get XML-Schema-learner working.
[mjo-overlay.git] / app-text / XML-Schema-learner / XML-Schema-learner-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 EGIT_REPO_URI="https://github.com/mjorlitzky/${PN}.git"
8 inherit git-2
9
10 DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
11 # See also:
12 # http://kore-nordmann.de/blog/0104_generating_xml_schemas_from_xml.html
13 HOMEPAGE="https://github.com/kore/XML-Schema-learner"
14 #SRC_URI=""
15
16 LICENSE="GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64"
19 IUSE="test"
20
21 DEPEND="test? ( dev-php/phpunit )"
22 RDEPEND="dev-lang/php[cli,xml,xmlreader]"
23
24 src_compile() {
25 # Don't run make, the default target is 'check'.
26 :
27 }
28
29 src_install() {
30 emake DESTDIR="${D}" PREFIX="/usr" install
31 }