]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - app-text/XML-Schema-learner/XML-Schema-learner-1.0.0.ebuild
app-text/XML-Schema-learner: Add a longdescription and remove unneeded stuff from...
[mjo-overlay.git] / app-text / XML-Schema-learner / XML-Schema-learner-1.0.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
8 HOMEPAGE="https://github.com/kore/${PN}"
9 SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE="test"
15
16 # PHP dependency can be inferred from .travis.yml in the repository.
17 DEPEND="test? ( dev-php/phpunit )"
18 RDEPEND="dev-lang/php[cli,xml,xmlreader]"
19
20 src_compile() {
21 # Don't run make, the default target is 'check'.
22 :
23 }
24
25 src_install() {
26 emake DESTDIR="${D}" PREFIX="/usr" install
27 }