]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - app-misc/reptyr/reptyr-0.2.ebuild
Added an ebuild for reptyr.
[mjo-overlay.git] / app-misc / reptyr / reptyr-0.2.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 DESCRIPTION="Reparent a running program to a new terminal"
8 HOMEPAGE="https://github.com/nelhage/${PN}"
9 SRC_URI="http://github.com/nelhage/${PN}/tarball/${P} -> ${P}.tar.gz"
10
11 LICENSE="MIT"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 src_unpack() {
17 unpack ${A}
18 mv "nelhage-${PN}"-* "${S}"
19 }
20
21 src_compile() {
22 emake CFLAGS="${CFLAGS}" || die "emake failed"
23 }
24
25 src_install() {
26 emake DESTDIR="${D}" PREFIX="/usr" install || die "install failed"
27 }