]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - app-admin/eselect-postgresql/eselect-postgresql-1.2.1.ebuild
Remove sys-process/xjobs for inclusion in gentoo-x86.
[mjo-overlay.git] / app-admin / eselect-postgresql / eselect-postgresql-1.2.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-postgresql/eselect-postgresql-1.2.1.ebuild,v 1.10 2014/01/26 12:10:29 ago Exp $
4
5 EAPI="5"
6
7 inherit multilib
8
9 DESCRIPTION="Utility to select the default PostgreSQL slot"
10 HOMEPAGE="http://www.gentoo.org/"
11 SRC_URI="http://dev.gentoo.org/~titanofold/${P}.tbz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
15 IUSE=""
16
17 RDEPEND="app-admin/eselect"
18
19 src_install() {
20 keepdir /etc/eselect/postgresql
21
22 insinto /usr/share/eselect/modules
23 doins postgresql.eselect
24
25 dosym /usr/bin/eselect /usr/bin/postgresql-config
26
27 # Create an env.d file that will append the currently-selected
28 # Postgres's pkgconfig path to the PKG_CONFIG_PATH environment
29 # variable. See bug #512236.
30 local pcp="${EPREFIX}/usr/$(get_libdir)/postgresql/pkgconfig"
31 echo "PKG_CONFIG_PATH=\"${pcp}\"" > "${T}"/99postgresql
32
33 doenvd "${T}"/99postgresql
34 }
35
36 pkg_postinst() {
37 postgresql-config update
38 }