]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - app-admin/eselect-postgresql/eselect-postgresql-1.2.1.ebuild
Add eselect-postgresql from portage.
[mjo-overlay.git] / app-admin / eselect-postgresql / eselect-postgresql-1.2.1.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-postgresql/eselect-postgresql-1.2.1.ebuild,v 1.10 2014/01/26 12:10:29 ago Exp $
4
5 EAPI="5"
6
7 DESCRIPTION="Utility to select the default PostgreSQL slot"
8 HOMEPAGE="http://www.gentoo.org/"
9 SRC_URI="http://dev.gentoo.org/~titanofold/${P}.tbz2"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
13 IUSE=""
14
15 RDEPEND="app-admin/eselect"
16
17 src_install() {
18 keepdir /etc/eselect/postgresql
19
20 insinto /usr/share/eselect/modules
21 doins postgresql.eselect
22
23 dosym /usr/bin/eselect /usr/bin/postgresql-config
24 }
25
26 pkg_postinst() {
27 postgresql-config update
28 }