]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sys-fs/e4rat/e4rat-0.1.5.ebuild
Fix the --as-needed error with a patch.
[mjo-overlay.git] / sys-fs / e4rat / e4rat-0.1.5.ebuild
index 8ca63a83d9fba13d1f611685bd9f2d84068fccb0..abe299b3c359cea4775568f18652130d5aed1e22 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Header: $
 
-inherit cmake-utils flag-o-matic
+inherit cmake-utils
 
 DESCRIPTION="Toolset to accelerate the boot process and application startup"
 HOMEPAGE="http://e4rat.sourceforge.net/"
@@ -20,13 +20,10 @@ DEPEND="dev-lang/perl
 
 RDEPEND="${DEPEND}"
 
+CMAKE_BUILD_TYPE=release
 CMAKE_IN_SOURCE_BUILD=1
-PATCHES=( "${FILESDIR}/cmake_mkdir_violation_fix.patch" )
-
-src_compile() {
-       filter-ldflags "-Wl,--as-needed"
-       cmake-utils_src_compile
-}
+PATCHES=( "${FILESDIR}/cmake_mkdir_violation_fix.patch"
+       "${FILESDIR}/v0.1.5_as-needed_fix.patch" )
 
 pkg_preinst() {
        dodir /var/lib/e4rat