]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sys-apps/logwatch/logwatch-7.4.0_p170-r1.ebuild
Add logwatch-7.4.0_p170-r1 to fix a file collision.
[mjo-overlay.git] / sys-apps / logwatch / logwatch-7.4.0_p170-r1.ebuild
diff --git a/sys-apps/logwatch/logwatch-7.4.0_p170-r1.ebuild b/sys-apps/logwatch/logwatch-7.4.0_p170-r1.ebuild
new file mode 100644 (file)
index 0000000..f4579fb
--- /dev/null
@@ -0,0 +1,87 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+#SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+SRC_URI="http://dev.gentoo.org/~polynomial-c/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+       virtual/mta
+       virtual/mailx
+       dev-lang/perl
+       dev-perl/Date-Calc
+       dev-perl/DateManip
+       dev-perl/Tie-IxHash
+       dev-perl/Sys-CPU
+       dev-perl/Sys-MemInfo"
+
+src_prepare() {
+       epatch "${FILESDIR}/${P/_p*}-openssh-hpn.patch"
+}
+
+src_install() {
+       dodir /usr/share/logwatch/lib
+       dodir /usr/share/logwatch/scripts/services
+       dodir /usr/share/logwatch/scripts/shared
+       dodir /usr/share/logwatch/default.conf/logfiles
+       dodir /usr/share/logwatch/default.conf/services
+       dodir /usr/share/logwatch/default.conf/html
+       keepdir /etc/logwatch
+       keepdir /var/cache/logwatch
+
+       newsbin scripts/logwatch.pl logwatch.pl || die "dosbin logwatch failed"
+
+       for i in scripts/logfiles/* ; do
+               exeinto /usr/share/logwatch/$i
+               doexe $i/* || die "doexe $i failed"
+       done
+
+       exeinto /usr/share/logwatch/lib
+       doexe lib/*.pm
+
+       exeinto /usr/share/logwatch/scripts/services
+       doexe scripts/services/*
+
+       exeinto /usr/share/logwatch/scripts/shared
+       doexe scripts/shared/*
+
+       insinto /usr/share/logwatch/default.conf
+       doins conf/logwatch.conf
+
+       insinto /usr/share/logwatch/default.conf/logfiles
+       doins conf/logfiles/*
+
+       insinto /usr/share/logwatch/default.conf/services
+       doins conf/services/*
+
+       insinto /usr/share/logwatch/default.conf/html
+       doins conf/html/*
+
+       # Make sure logwatch is run before anything else #100243
+       exeinto /etc/cron.daily
+       newexe "${FILESDIR}"/logwatch 00-logwatch
+
+       doman logwatch.8
+       dodoc README HOWTO-Customize-LogWatch
+}
+
+pkg_postinst() {
+       if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+               local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+               [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+                       && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+                       || ewarn "You have two logwatch files in /etc/cron.daily/"
+       fi
+}