]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sci-mathematics/rw/rw-0.7.ebuild
Finish (?) sci-mathematics/rw ebuild.
[mjo-overlay.git] / sci-mathematics / rw / rw-0.7.ebuild
index 91d52f474f3d7e43bb3fd35e9683ed4e07922cc9..0e4a4480c92465e5f38f26dce0c0586225b0a136 100644 (file)
@@ -11,12 +11,28 @@ SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
 
 LICENSE="GPL-2+"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="executable"
+KEYWORDS="~amd64"
+IUSE="+executable"
 
 DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
 RDEPEND="${DEPEND}"
 
+DOCDIR="/usr/share/doc/${PF}"
+
 src_configure(){
-       econf $(use_enable executable)
+       econf $(use_enable executable) \
+                 --docdir="${EPREFIX}${DOCDIR}"
+}
+
+src_install(){
+       # This isn't strictly necessary, but it keeps the examples separated
+       # in a subdirectory. It also prevents the example graphs from being
+       # compressed, which is good, since they're supposed to be fed into
+       # the 'rw' program and it doesn't understand bzip2.
+       emake DESTDIR="${D}" install-exec
+       dodoc AUTHORS README NEWS
+
+       insinto "${DOCDIR}"
+       docompress -x "${DOCDIR}/example_graphs"
+       doins -r example_graphs
 }