]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sci-mathematics/rw/rw-0.7.ebuild
sci-mathematics/rw: new package (currently doesn't work, website down).
[mjo-overlay.git] / sci-mathematics / rw / rw-0.7.ebuild
diff --git a/sci-mathematics/rw/rw-0.7.ebuild b/sci-mathematics/rw/rw-0.7.ebuild
new file mode 100644 (file)
index 0000000..91d52f4
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Compute rank-width decompositions of graphs"
+AUTHORPAGE="http://pholia.tdi.informatik.uni-frankfurt.de/~philipp/"
+HOMEPAGE="${AUTHORPAGE}software/${PN}.shtml"
+SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable"
+
+DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+       econf $(use_enable executable)
+}