]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-proxy/torsocks/torsocks-2.0.0.ebuild
net-proxy/torsocks: disable network tests.
[mjo-overlay.git] / net-proxy / torsocks / torsocks-2.0.0.ebuild
index c7e4611575b562feaffa91ba5146ed90d41b5cdf..57c29df23a6ca13c0d7e8da67465e49672eeb7a3 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/torsocks/torsocks-2.0.0.ebuild,v 1.1 2014/12/21 21:34:58 mrueg Exp $
+# $Header: $
 
 EAPI=5
 
@@ -25,6 +25,11 @@ RDEPEND="${DEPEND}"
 
 src_prepare() {
        sed -i -e "/dist_doc_DATA/s/^/#/" Makefile.am doc/Makefile.am || die
+
+       # Disable tests requiring network access.
+       sed -i -e '/^\.\/test_dns$/d' tests/test_list || \
+         die "failed to disable network tests"
+
        eautoreconf
 }