]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-mail/postfix-logwatch/postfix-logwatch-1.40.00.ebuild
Bump postfix-logwatch to 1.40.00 which has a license change and a few fixes.
[mjo-overlay.git] / net-mail / postfix-logwatch / postfix-logwatch-1.40.00.ebuild
similarity index 73%
rename from net-mail/postfix-logwatch/postfix-logwatch-1.39.07.ebuild
rename to net-mail/postfix-logwatch/postfix-logwatch-1.40.00.ebuild
index ab85c5b2bb9b3fad589264667992c6731b9c48ee..dfb853366556728c436035f602d8ad864ab57229 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/postfix-logwatch/postfix-logwatch-1.39.07.ebuild,v 1.1 2013/12/03 13:28:25 mjo Exp $
+# $Header: $
 
 EAPI=5
 
@@ -8,13 +8,21 @@ DESCRIPTION="A log analyzer for postfix"
 HOMEPAGE="http://logreporters.sourceforge.net/"
 SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
 
-LICENSE="GPL-2"
+LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64"
 IUSE="logwatch"
 
 RDEPEND="dev-lang/perl"
 
+src_prepare() {
+       # Replace the default config file location with ours.
+       local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+       local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+       sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+               || die 'failed to update the default config location'
+}
+
 src_compile() {
        # The default make target just outputs instructions. We don't want
        # the user to see these, so we avoid the default emake.
@@ -36,6 +44,10 @@ src_install() {
                # Remove the taint mode (-T) switch from the header of the
                # standalone executable, and save the result as our logwatch
                # filter.
+               #
+               # We don't do this for the standalone script because it's nice
+               # to have the taint flag when it works.
+               #
                sed 's~^#!/usr/bin/perl -T$~#!/usr/bin/perl~' ${PN} > postfix \
                        || die "failed to remove the perl taint switch"