]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-mail/amavis-logwatch/amavis-logwatch-1.51.02.ebuild
Add notes about upstream logwatch script inclusion.
[mjo-overlay.git] / net-mail / amavis-logwatch / amavis-logwatch-1.51.02.ebuild
index fa0b005abe0ca8b9cb27409664bc1801eef6b053..3a1ee81ea8bd79c97f23a3b1e7348888c1adfdb7 100644 (file)
@@ -4,8 +4,6 @@
 
 EAPI=5
 
-inherit eutils
-
 DESCRIPTION="A log analyzer for amavisd-new"
 HOMEPAGE="http://logreporters.sourceforge.net/"
 SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
@@ -13,12 +11,19 @@ SRC_URI="mirror://sourceforge/logreporters/${P}.tgz"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64"
+
+# >=sys-apps/logwatch-7.4.0_p170 ships our logwatch scripts and will
+# thus obsolete this use flag.
 IUSE="logwatch"
 
 RDEPEND="dev-lang/perl"
 
 src_prepare() {
-       epatch "${FILESDIR}/default_config_location.patch"
+       # Replace the default config file location with ours.
+       local cfg_default='/usr/local/etc/${progname_prefix}-logwatch.conf'
+       local cfg_gentoo='/etc/${progname_prefix}-logwatch.conf';
+       sed -i "s~${cfg_default}~${cfg_gentoo}~" ${PN} \
+               || die 'failed to update the default config location'
 }
 
 src_compile() {
@@ -42,8 +47,12 @@ src_install() {
                # Remove the taint mode (-T) switch from the header of the
                # standalone executable, and save the result as our logwatch
                # filter.
+               #
+               # We don't do this for the standalone script because it's nice
+               # to have the taint flag when it works.
+               #
                sed 's~^#!/usr/bin/perl -T$~#!/usr/bin/perl~' ${PN} > amavis \
-                       || die "failed to remove the perl taint switch"
+                       || die 'failed to remove the perl taint switch'
 
                insinto /etc/logwatch/scripts/services
                doins amavis