]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-dns/djbdns/djbdns-1.05-r26.ebuild
Add skeleton metadata.xml for visual-basic-mode.
[mjo-overlay.git] / net-dns / djbdns / djbdns-1.05-r26.ebuild
index 0f6229e06ba3c989d58fad6fa629ef7a42a4bcd2..85a4158331814cfc60e00838c18adb413e2fc8a4 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r26.ebuild,v 1.5 2012/07/25 01:53:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r26.ebuild,v 1.8 2013/01/05 23:03:04 pinkbyte Exp $
 
 EAPI="2"
 inherit eutils flag-o-matic toolchain-funcs user
@@ -14,7 +14,7 @@ SRC_URI="http://cr.yp.to/djbdns/${P}.tar.gz
 
 SLOT="0"
 LICENSE="public-domain"
-KEYWORDS="~alpha ~amd64 hppa ~mips ppc ppc64 ~sparc x86"
+KEYWORDS="alpha amd64 hppa ~mips ppc ppc64 sparc x86"
 IUSE="doc ipv6 selinux static"
 
 DEPEND=""
@@ -32,7 +32,7 @@ src_prepare() {
        elog 'of custom patches.'
        elog
        elog 'Some of them can be found at http://tinydns.org/ or'
-       elog 'http://homepages.tesco.net/J.deBoynePollard/Softwares/djbdns/'
+       elog 'http://homepage.ntlworld.com/jonathan.deboynepollard/Softwares/djbdns/'
        elog
 
        epatch \
@@ -46,7 +46,7 @@ src_prepare() {
 
        if use ipv6; then
                elog "At present dnstrace does NOT support IPv6. It will"\
-                        "be compiled without IPv6 support."
+                    "be compiled without IPv6 support."
                cp -pR "${S}" "${S}-noipv6"
                # Careful -- >=test21 of the IPv6 patch includes the errno patch
                epatch "${DISTDIR}/${P}-${IPV6_PATCH}.diff.bz2"
@@ -115,6 +115,10 @@ src_install() {
        fi
 
        dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION || die
+
+       dobin "${FILESDIR}/dnscache-setup" || die
+       dobin "${FILESDIR}/tinydns-setup" || die
+       dobin "${FILESDIR}/djbdns-setup" || die
 }
 
 pkg_preinst() {
@@ -128,33 +132,5 @@ pkg_preinst() {
 }
 
 pkg_postinst() {
-       elog ''
-       elog 'The dnscache-setup, tinydns-setup, and djbdns-setup programs have'
-       elog 'been removed to follow upstream more closely. To configure djbdns,'
-       elog 'please follow the instructions at,'
-       elog ''
-       elog '  http://cr.yp.to/djbdns.html'
-       elog ''
-       elog 'Of particular interest are,'
-       elog ''
-       elog '  axfrdns : http://cr.yp.to/djbdns/axfrdns-conf.html'
-       elog '  dnscache: http://cr.yp.to/djbdns/run-cache-x-home.html'
-       elog '  tinydns : http://cr.yp.to/djbdns/run-server.html'
-       elog ''
-       elog 'Portage has created users for axfrdns, dnscache, and tinydns; the'
-       elog 'commands to configure these programs are,'
-       elog ''
-       elog '  1. axfrdns-conf tinydns dnslog /var/axfrdns /var/tinydns $ip'
-       elog '  2. dnscache-conf dnscache dnslog /var/dnscache $ip'
-       elog '  3. tinydns-conf tinydns dnslog /var/tinydns $ip'
-       elog ''
-       elog '(replace $ip with the ip address on which the server will run).'
-       elog ''
-       elog 'If you wish to configure rbldns or walldns, you will need to create'
-       elog 'those users yourself (although you should still use the "dnslog"'
-       elog 'user for the logs):'
-       elog ''
-       elog '  4. rbldns-conf $username dnslog /var/rbldns $ip $base'
-       elog '  5. walldns-conf $username dnslog /var/walldns $ip'
-       elog ''
+       elog "Use dnscache-setup & tinydns-setup or djbdns-setup to configure djbdns."
 }