]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-dns/djbdns/djbdns-1.05-r25.ebuild
Actually revert to portage current.
[mjo-overlay.git] / net-dns / djbdns / djbdns-1.05-r25.ebuild
index e05f6ba5196da854e6deacd5583c7ff33b7fa2fc..b947cacd19b81d8c3dddbe1b7ddae2aca3e708da 100644 (file)
@@ -1,9 +1,9 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r25.ebuild,v 1.2 2012/03/24 09:26:17 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r25.ebuild,v 1.3 2012/06/14 02:04:37 zmedico Exp $
 
 EAPI="2"
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs user
 
 DESCRIPTION="Excellent high-performance DNS services"
 HOMEPAGE="http://cr.yp.to/djbdns.html"
@@ -27,13 +27,12 @@ RDEPEND="${DEPEND}
 
 src_prepare() {
        echo
-       elog 'Several patches have been dropped from this ebuild.'
-       elog 'Please place custom patches in,'
-       elog
-       elog '  /etc/portage/patches/net-dns/djbdns'
+       elog 'Several patches have been dropped from this djbdns ebuild revision.'
+       elog 'Please use the DJBDNS_PATCH_DIR variable to specify a directory'
+       elog 'of custom patches.'
        elog
        elog 'Some of them can be found at http://tinydns.org/ or'
-       elog 'http://homepage.ntlworld.com/jonathan.deboynepollard/Softwares/djbdns/'
+       elog 'http://homepages.tesco.net/J.deBoynePollard/Softwares/djbdns/'
        elog
 
        epatch \
@@ -47,7 +46,7 @@ src_prepare() {
 
        if use ipv6; then
                elog "At present dnstrace does NOT support IPv6. It will"\
-                        "be compiled without IPv6 support."
+                    "be compiled without IPv6 support."
                cp -pR "${S}" "${S}-noipv6"
                # Careful -- >=test21 of the IPv6 patch includes the errno patch
                epatch "${DISTDIR}/${P}-${IPV6_PATCH}.diff.bz2"
@@ -68,8 +67,16 @@ src_prepare() {
 
        epatch "${FILESDIR}/${PV}-errno.patch"
 
-       cd "${S}"
-       epatch_user
+       if [[ -n "${DJBDNS_PATCH_DIR}" && -d "${DJBDNS_PATCH_DIR}" ]]
+       then
+               echo
+               ewarn "You enabled custom patches from ${DJBDNS_PATCH_DIR}."
+               ewarn "Be warned that you won't get any support when using "
+               ewarn "this feature. You're on your own from now!"
+               echo
+               ebeep
+               cd "${S}" && epatch "${DJBDNS_PATCH_DIR}/"*
+       fi
 }
 
 src_compile() {