]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-dns/djbdns/djbdns-1.05-r25.ebuild
Remove sys-apps/apply-default-acl, I can wait for it to show up in portage.
[mjo-overlay.git] / net-dns / djbdns / djbdns-1.05-r25.ebuild
index 8e8da1641e57a2b37ba66653c8e71d71493817cf..b947cacd19b81d8c3dddbe1b7ddae2aca3e708da 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.3 2011/04/04 18:58:49 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r25.ebuild,v 1.3 2012/06/14 02:04:37 zmedico Exp $
 
 EAPI="2"
-inherit eutils flag-o-matic toolchain-funcs
+inherit eutils flag-o-matic toolchain-funcs user
 
 DESCRIPTION="Excellent high-performance DNS services"
 HOMEPAGE="http://cr.yp.to/djbdns.html"
@@ -37,7 +37,7 @@ src_prepare() {
 
        epatch \
                "${FILESDIR}/headtail.patch" \
-               "${FILESDIR}/dnsroots-r25.patch" \
+               "${FILESDIR}/dnsroots.patch" \
                "${FILESDIR}/dnstracesort.patch" \
                "${FILESDIR}/string_length_255.patch"
 
@@ -54,7 +54,8 @@ src_prepare() {
                # Fix CVE2008-4392
                epatch \
                        "${FILESDIR}/CVE2008-4392_0001-dnscache-merge-similar-outgoing-queries-ipv6.patch" \
-                       "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch"
+                       "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch" \
+                       "${FILESDIR}/makefile-parallel.patch"
 
                cd "${S}-noipv6"
        fi
@@ -117,11 +118,14 @@ src_install() {
 
        dobin "${FILESDIR}/dnscache-setup" || die
        dobin "${FILESDIR}/tinydns-setup" || die
-       newbin "${FILESDIR}/djbdns-setup-r17" djbdns-setup || die
+       dobin "${FILESDIR}/djbdns-setup" || die
 }
 
 pkg_preinst() {
-       # The nofiles group is provided by baselayout
+       # The nofiles group is no longer provided by baselayout.
+       # Share it with qmail if possible.
+       enewgroup nofiles 200
+
        enewuser dnscache -1 -1 -1 nofiles
        enewuser dnslog -1 -1 -1 nofiles
        enewuser tinydns -1 -1 -1 nofiles