]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-dns/djbdns/djbdns-1.05-r24.ebuild
Fix the patch URL in the elog output.
[mjo-overlay.git] / net-dns / djbdns / djbdns-1.05-r24.ebuild
index 52dc0a649da37a99dbcf05be6e84c3d82256d664..715edbc289450cc27bdb4a45ef6bf7e5b7e9ffd9 100644 (file)
@@ -27,12 +27,13 @@ RDEPEND="${DEPEND}
 
 src_prepare() {
        echo
-       elog 'Several patches have been dropped from this djbdns ebuild revision.'
-       elog 'Please use the DJBDNS_PATCH_DIR variable to specify a directory'
-       elog 'of custom patches.'
+       elog 'Several patches have been dropped from this ebuild.'
+       elog 'Please place custom patches in,'
+       elog
+       elog '  /etc/portage/patches/net-dns/djbdns'
        elog
        elog 'Some of them can be found at http://tinydns.org/ or'
-       elog 'http://homepages.tesco.net/J.deBoynePollard/Softwares/djbdns/'
+       elog 'http://homepage.ntlworld.com/jonathan.deboynepollard/Softwares/djbdns/'
        elog
 
        epatch \
@@ -46,7 +47,7 @@ src_prepare() {
 
        if use ipv6; then
                elog "At present dnstrace does NOT support IPv6. It will"\
-                    "be compiled without IPv6 support."
+                        "be compiled without IPv6 support."
                cp -pR "${S}" "${S}-noipv6"
                # Careful -- >=test21 of the IPv6 patch includes the errno patch
                epatch "${DISTDIR}/${P}-${IPV6_PATCH}.diff.bz2"
@@ -67,16 +68,8 @@ src_prepare() {
 
        epatch "${FILESDIR}/${PV}-errno.patch"
 
-       if [[ -n "${DJBDNS_PATCH_DIR}" && -d "${DJBDNS_PATCH_DIR}" ]]
-       then
-               echo
-               ewarn "You enabled custom patches from ${DJBDNS_PATCH_DIR}."
-               ewarn "Be warned that you won't get any support when using "
-               ewarn "this feature. You're on your own from now!"
-               echo
-               ebeep
-               cd "${S}" && epatch "${DJBDNS_PATCH_DIR}/"*
-       fi
+       cd "${S}"
+       epatch_user
 }
 
 src_compile() {