]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-analyzer/pnp4nagios/pnp4nagios-0.6.25.ebuild
net-analyzer/pnp4nagios: version bump fixing nagios dep and permissions.
[mjo-overlay.git] / net-analyzer / pnp4nagios / pnp4nagios-0.6.25.ebuild
similarity index 80%
rename from net-analyzer/pnp4nagios/pnp4nagios-0.6.24-r1.ebuild
rename to net-analyzer/pnp4nagios/pnp4nagios-0.6.25.ebuild
index 93ae57243e1cdf2564840583125e2ec620b8e2df..2bde2932322ba628d16c17501fa929f0db191552 100644 (file)
@@ -15,11 +15,12 @@ SLOT="0"
 IUSE=""
 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
 
+# A lot of things (sync mode, for one) are broken with nagios-4.x.
 DEPEND="
        dev-lang/php[json,simplexml,zlib,xml,filter]
        >=dev-lang/php-5.3
        >=net-analyzer/rrdtool-1.2[graph,perl]
-       || ( net-analyzer/nagios-core net-analyzer/icinga net-analyzer/icinga2 )"
+       || ( <net-analyzer/nagios-core-4 net-analyzer/icinga net-analyzer/icinga2 )"
 
 # A list of modules used in our Apache config file.
 APACHE_MODS="apache2_modules_alias,"       # "Alias" directive
@@ -81,6 +82,11 @@ src_install() {
        if use apache2 ; then
                insinto "${APACHE_MODULES_CONFDIR}"
                newins "${FILESDIR}"/98_pnp4nagios-2.4.conf 98_pnp4nagios.conf
+
+               # Allow the apache user to read our config files. This same
+               # approach is used in net-analyzer/nagios-core.
+               chgrp -R apache "${D}/etc/pnp" \
+                       || die "failed to change group of ${ROOT}etc/pnp"
        fi
 
        # Bug 430358 - CVE-2012-3457
@@ -92,6 +98,10 @@ src_install() {
 }
 
 pkg_postinst() {
-       elog "Please make sure to enable URL rewriting in Apache or any other"
-       elog "webserver you're using, to get pnp4nagios running!"
+       elog "To enable the pnp4nagios web front-end, please visit"
+       elog "${ROOT}etc/conf.d/apache2 and add \"-D PNP -D PHP5\""
+       elog "to APACHE2_OPTS. Then pnp4nagios will be available at,"
+       elog
+       elog "  http://localhost/pnp4nagios"
+       elog
 }