]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-analyzer/pnp4nagios/pnp4nagios-0.6.24-r1.ebuild
net-analyzer/pnp4nagios: Revbump for apache-2.4 support.
[mjo-overlay.git] / net-analyzer / pnp4nagios / pnp4nagios-0.6.24-r1.ebuild
similarity index 60%
rename from net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild
rename to net-analyzer/pnp4nagios/pnp4nagios-0.6.24-r1.ebuild
index b94e1a166a074513f02490f3e714528fb44c6709..93ae57243e1cdf2564840583125e2ec620b8e2df 100644 (file)
@@ -1,31 +1,39 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pnp4nagios/pnp4nagios-0.6.24.ebuild,v 1.5 2014/11/10 13:51:44 ago Exp $
+# $Header: $
 
 EAPI=5
 
 inherit depend.apache eutils
 
 DESCRIPTION="A performance data analyzer for nagios"
-HOMEPAGE="http://www.pnp4nagios.org"
+HOMEPAGE="http://www.pnp4nagios.org/"
 SRC_URI="mirror://sourceforge/${PN}/PNP-0.6/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
 IUSE=""
-KEYWORDS="amd64 ppc ppc64 ~sparc x86"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
 
 DEPEND="
        dev-lang/php[json,simplexml,zlib,xml,filter]
        >=dev-lang/php-5.3
        >=net-analyzer/rrdtool-1.2[graph,perl]
        || ( net-analyzer/nagios-core net-analyzer/icinga net-analyzer/icinga2 )"
+
+# A list of modules used in our Apache config file.
+APACHE_MODS="apache2_modules_alias,"       # "Alias" directive
+APACHE_MODS+="apache2_modules_authz_core," # "Require" directive
+APACHE_MODS+="apache2_modules_rewrite"     # "RewriteEngine" and friends
+
 RDEPEND="${DEPEND}
        virtual/perl-Getopt-Long
        virtual/perl-Time-HiRes
        media-fonts/dejavu
-       apache2? ( www-servers/apache[apache2_modules_rewrite] )"
+       apache2? ( >=www-servers/apache-2.4[${APACHE_MODS}] )"
 
+# There is no want_apache2_4, but we needed to specify that manually
+# anyway to be able to include the list of modules.
 want_apache2
 
 pkg_setup() {
@@ -33,7 +41,7 @@ pkg_setup() {
 }
 
 src_prepare() {
-       epatch "${FILESDIR}"/${PN}-0.6.14-makefile.patch
+       epatch "${FILESDIR}/${PN}-0.6.14-makefile.patch"
 }
 
 src_configure() {
@@ -67,16 +75,20 @@ src_compile() {
 src_install() {
        emake DESTDIR="${D}" install install-config
        newinitd "${FILESDIR}"/npcd.initd npcd
-       rm "${D}"/usr/share/pnp/install.php || die
+       rm "${D}/usr/share/pnp/install.php" || \
+               die "unable to remove ${D}/usr/share/pnp/install.php"
 
        if use apache2 ; then
                insinto "${APACHE_MODULES_CONFDIR}"
-               doins "${FILESDIR}"/98_pnp4nagios.conf
+               newins "${FILESDIR}"/98_pnp4nagios-2.4.conf 98_pnp4nagios.conf
        fi
 
        # Bug 430358 - CVE-2012-3457
-       find "${D}/etc/pnp" -type f -exec chmod 0640 {} \; || die
-       find "${D}/etc/pnp" -type d -exec chmod 0750 {} \; || die
+       find "${D}/etc/pnp" -type f -exec chmod 0640 '{}' + || \
+               die "unable to set file permissions under ${D}/etc/pnp"
+
+       find "${D}/etc/pnp" -type d -exec chmod 0750 '{}' + || \
+               die "unable to set directory permissions under ${D}/etc/pnp"
 }
 
 pkg_postinst() {