]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.0.ebuild
Add net-analyzer/nagios-check_rbl-1.3.0.
[mjo-overlay.git] / net-analyzer / nagios-check_rbl / nagios-check_rbl-1.3.0.ebuild
diff --git a/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.0.ebuild b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.0.ebuild
new file mode 100644 (file)
index 0000000..ad624b7
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="check_rbl is a Nagios plugin that fails if a host is blacklisted"
+HOMEPAGE="https://svn.id.ethz.ch/projects/nagios_plugins/wiki/check_rbl"
+
+MY_P="${P/nagios-/}"
+
+SRC_URI="https://svn.id.ethz.ch/projects/nagios_plugins/downloads/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+# The Makefile.PL looks for Nagios::Plugin::Getopt and
+# Nagios::Plugin::Threshold, but I believe these are provided by
+# dev-perl/Nagios-Plugins.
+RDEPEND="dev-lang/perl
+       dev-perl/Nagios-Plugin
+       dev-perl/Net-DNS
+       dev-perl/Readonly"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+       local dest="/usr/$(get_libdir)/nagios/plugins"
+       perl Makefile.PL INSTALLSCRIPT="${dest}"
+}