]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.9.ebuild
Remove redundant "if use oci8-instant-client" check.
[mjo-overlay.git] / dev-lang / php / php-5.6.9.ebuild
index 823087ebfa1686e5b38b6fc66aeb28f281f93020..d96ff1afa5c564189b03adeb99ee4c8150db6e4b 100644 (file)
@@ -439,11 +439,8 @@ src_configure() {
        fi
 
        # Interbase/firebird support
-
-       if use firebird ; then
-               my_conf+="
-               $(use_with firebird interbase ${EPREFIX}/usr)"
-       fi
+       my_conf+="
+       $(use_with firebird interbase ${EPREFIX}/usr)"
 
        # LDAP support
        if use ldap ; then
@@ -469,21 +466,13 @@ src_configure() {
        fi
 
        # ODBC support
-       if use odbc ; then
-               my_conf+="
-               $(use_with odbc unixODBC ${EPREFIX}/usr)"
-       fi
-
-       if use iodbc ; then
-               my_conf+="
-               $(use_with iodbc iodbc ${EPREFIX}/usr)"
-       fi
+       my_conf+="
+       $(use_with odbc unixODBC ${EPREFIX}/usr)
+       $(use_with iodbc iodbc ${EPREFIX}/usr)"
 
        # Oracle support
-       if use oci8-instant-client ; then
-               my_conf+="
-               $(use_with oci8-instant-client oci8)"
-       fi
+       my_conf+="
+       $(use_with oci8-instant-client oci8)"
 
        # PDO support
        if use pdo ; then