]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.9.ebuild
Remove second redundant "if use oci8-instant-client" check (for PDO this time).
[mjo-overlay.git] / dev-lang / php / php-5.6.9.ebuild
index 72cb4cf797a0cfe11bf774f11f2d72ee1c4d48b3..933d1248afb9cbb9390ab6d82ffb8210e6d4e359 100644 (file)
@@ -467,18 +467,12 @@ src_configure() {
 
        # ODBC support
        my_conf+="
-       $(use_with odbc unixODBC ${EPREFIX}/usr)"
-
-       if use iodbc ; then
-               my_conf+="
-               $(use_with iodbc iodbc ${EPREFIX}/usr)"
-       fi
+       $(use_with odbc unixODBC ${EPREFIX}/usr)
+       $(use_with iodbc iodbc ${EPREFIX}/usr)"
 
        # Oracle support
-       if use oci8-instant-client ; then
-               my_conf+="
-               $(use_with oci8-instant-client oci8)"
-       fi
+       my_conf+="
+       $(use_with oci8-instant-client oci8)"
 
        # PDO support
        if use pdo ; then
@@ -487,11 +481,8 @@ src_configure() {
                $(use_with mysql pdo-mysql ${mysqllib})
                $(use_with postgres pdo-pgsql )
                $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
-               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
-               if use oci8-instant-client ; then
-                       my_conf+="
-                       $(use_with oci8-instant-client pdo-oci)"
-               fi
+               $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)
+               $(use_with oci8-instant-client pdo-oci)"
        fi
 
        # readline/libedit support