]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Combine readline/libedit and other use_with statements.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index e8cfae0d02c26412873101415313fa78d1b9ab14..c76611dd571aaac553db5b597f6ac65e649593ba 100644 (file)
@@ -363,6 +363,9 @@ src_configure() {
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
+       $(use_with   ldap ldap "${EPREFIX}"/usr)
+       $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
+       $(use_with   libedit libedit "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
@@ -375,6 +378,7 @@ src_configure() {
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
        $(use_with   spell pspell "${EPREFIX}"/usr)
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
        $(use_with   spell pspell "${EPREFIX}"/usr)
+       $(use_with   readline readline "${EPREFIX}"/usr)
        $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
        $(use_enable simplexml simplexml )
        $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
        $(use_enable simplexml simplexml )
@@ -438,13 +442,6 @@ src_configure() {
                my_conf+="$(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
                my_conf+="$(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
-       # LDAP support
-       if use ldap ; then
-               my_conf+="
-               $(use_with ldap ldap ${EPREFIX}/usr)
-               $(use_with ldap-sasl ldap-sasl ${EPREFIX}/usr)"
-       fi
-
        # MySQL support
        local mysqllib="mysqlnd"
        local mysqlilib="mysqlnd"
        # MySQL support
        local mysqllib="mysqlnd"
        local mysqlilib="mysqlnd"
@@ -475,11 +472,6 @@ src_configure() {
                fi
        fi
 
                fi
        fi
 
-       # readline/libedit support
-       my_conf+="
-       $(use_with readline readline ${EPREFIX}/usr)
-       $(use_with libedit libedit ${EPREFIX}/usr)"
-
        # Session support
        if use session ; then
                my_conf+="
        # Session support
        if use session ; then
                my_conf+="