]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Add the pdo-pgsql USE flag.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index c76611dd571aaac553db5b597f6ac65e649593ba..a0e6dae00ee0a68792155f802ccfb72f2783bad7 100644 (file)
@@ -69,8 +69,8 @@ IUSE="${IUSE} bcmath berkdb bzip2 calendar cdb cjk
        flatfile ftp gd gdbm gmp +hash +iconv imap inifile
        intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit mhash
        mssql mysql libmysqlclient mysqli nls
-       oci8-instant-client odbc +opcache pcntl pdo +phar +posix postgres qdbm
-       readline recode selinux +session sharedmem
+       oci8-instant-client odbc +opcache pcntl pdo pdo-dblib pdo-pgsql
+       +phar +posix postgres qdbm readline recode selinux +session sharedmem
        +simplexml snmp soap sockets spell sqlite ssl
        sybase-ct sysvipc systemd tidy +tokenizer truetype unicode vpx wddx
        +xml xmlreader xmlwriter xmlrpc xpm xslt zip zlib"
@@ -178,6 +178,8 @@ REQUIRED_USE="
                pdo
        ) )
 
+       pdo-dblib? ( mssql )
+       pdo-pgsql? ( postgres )
        qdbm? ( !gdbm )
        readline? ( !libedit )
        recode? ( !imap !mysql !mysqli )
@@ -374,6 +376,8 @@ src_configure() {
        $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
        $(use_enable pdo pdo )
+       $(use_with   pdo-dblib pdo-dblib )
+       $(use_with   pdo-pgsql pdo-pgsql )
        $(use_enable phar phar )
        $(use_enable posix posix )
        $(use_with   postgres pgsql "${EPREFIX}"/usr)
@@ -461,9 +465,7 @@ src_configure() {
        # PDO support
        if use pdo ; then
                my_conf+="
-               $(use_with mssql pdo-dblib )
                $(use_with mysql pdo-mysql ${mysqllib})
-               $(use_with postgres pdo-pgsql )
                $(use_with sqlite pdo-sqlite ${EPREFIX}/usr)
                $(use_with odbc pdo-odbc unixODBC,${EPREFIX}/usr)"
                if use oci8-instant-client ; then