]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Remove redundant "if use firebird" check.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 6bff755d8a4c434289c3772e9d40eefb1f5f4229..9dfc351b11b63a87283566f912042746be53f79c 100644 (file)
@@ -352,11 +352,13 @@ src_configure() {
        $(use_enable exif exif )
        $(use_enable fileinfo fileinfo )
        $(use_enable filter filter )
+       $(use_with   firebird interbase "${EPREFIX}"/usr)
        $(use_enable ftp ftp )
        $(use_with   gmp gmp "${EPREFIX}"/usr)
        $(use_enable hash hash )
        $(use_with   iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
        $(use_enable intl intl )
+       $(use_with   iodbc iodbc "${EPREFIX}"/usr)
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
@@ -436,13 +438,6 @@ src_configure() {
                $(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
-       # Interbase/firebird support
-
-       if use firebird ; then
-               my_conf+="
-               $(use_with firebird interbase ${EPREFIX}/usr)"
-       fi
-
        # LDAP support
        if use ldap ; then
                my_conf+="
@@ -466,11 +461,6 @@ src_configure() {
                my_conf+="${mysqlsock}"
        fi
 
-       if use iodbc ; then
-               my_conf+="
-               $(use_with iodbc iodbc ${EPREFIX}/usr)"
-       fi
-
        # Oracle support
        if use oci8-instant-client ; then
                my_conf+="