]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Remove redundant "if use oci8-instant-client" check.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 79be81f97897977f85ac5da95f6671ae1db0f4aa..82182e2f37fca52185487a439a391c0e989fda87 100644 (file)
@@ -352,6 +352,7 @@ src_configure() {
        $(use_enable exif exif )
        $(use_enable fileinfo fileinfo )
        $(use_enable filter filter )
+       $(use_with   firebird interbase "${EPREFIX}"/usr)
        $(use_enable ftp ftp )
        $(use_with   gmp gmp "${EPREFIX}"/usr)
        $(use_enable hash hash )
@@ -364,6 +365,7 @@ src_configure() {
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
+       $(use_with   oci8-instant-client oci8)
        $(use_with   odbc unixODBC "${EPREFIX}"/usr)
        $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
@@ -437,13 +439,6 @@ src_configure() {
                $(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
-       # Interbase/firebird support
-
-       if use firebird ; then
-               my_conf+="
-               $(use_with firebird interbase ${EPREFIX}/usr)"
-       fi
-
        # LDAP support
        if use ldap ; then
                my_conf+="
@@ -467,12 +462,6 @@ src_configure() {
                my_conf+="${mysqlsock}"
        fi
 
-       # Oracle support
-       if use oci8-instant-client ; then
-               my_conf+="
-               $(use_with oci8-instant-client oci8)"
-       fi
-
        # PDO support
        if use pdo ; then
                my_conf+="