]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Remove redundant "if use oci8-instant-client" check.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 5b3b76b40d658584406c1555b426433f22bfb216..82182e2f37fca52185487a439a391c0e989fda87 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.6.4.ebuild,v 1.2 2014/12/28 15:27:17 titanofold Exp $
+# $Header: $
 
 EAPI=5
 
@@ -342,63 +342,67 @@ src_configure() {
        #                             extension           USE flag        shared
        my_conf+="
        $(use_enable bcmath bcmath )
-       $(use_with bzip2 bz2 "${EPREFIX}"/usr)
+       $(use_with   bzip2 bz2 "${EPREFIX}"/usr)
        $(use_enable calendar calendar )
+       $(use_with   crypt mcrypt "${EPREFIX}"/usr)
        $(use_enable ctype ctype )
-       $(use_with curl curl "${EPREFIX}"/usr)
-       $(use_enable xml dom )
-       $(use_with enchant enchant "${EPREFIX}"/usr)
+       $(use_with   curl curl "${EPREFIX}"/usr)
+       $(use_enable debug debug )
+       $(use_with   enchant enchant "${EPREFIX}"/usr)
        $(use_enable exif exif )
        $(use_enable fileinfo fileinfo )
        $(use_enable filter filter )
+       $(use_with   firebird interbase "${EPREFIX}"/usr)
        $(use_enable ftp ftp )
-       $(use_with nls gettext "${EPREFIX}"/usr)
-       $(use_with gmp gmp "${EPREFIX}"/usr)
+       $(use_with   gmp gmp "${EPREFIX}"/usr)
        $(use_enable hash hash )
-       $(use_with mhash mhash "${EPREFIX}"/usr)
-       $(use_with iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
+       $(use_with   iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
        $(use_enable intl intl )
+       $(use_with   iodbc iodbc "${EPREFIX}"/usr)
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
-       $(use_with kerberos kerberos "${EPREFIX}"/usr)
-       $(use_enable xml libxml )
-       $(use_with xml libxml-dir "${EPREFIX}"/usr)
-       $(use_enable unicode mbstring )
-       $(use_with crypt mcrypt "${EPREFIX}"/usr)
-       $(use_with mssql mssql "${EPREFIX}"/usr)
-       $(use_with unicode onig "${EPREFIX}"/usr)
-       $(use_with ssl openssl "${EPREFIX}"/usr)
-       $(use_with ssl openssl-dir "${EPREFIX}"/usr)
+       $(use_with   kerberos kerberos "${EPREFIX}"/usr)
+       $(use_with   mhash mhash "${EPREFIX}"/usr)
+       $(use_with   mssql mssql "${EPREFIX}"/usr)
+       $(use_with   nls gettext "${EPREFIX}"/usr)
+       $(use_with   oci8-instant-client oci8)
+       $(use_with   odbc unixODBC "${EPREFIX}"/usr)
+       $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
-       $(use_enable phar phar )
        $(use_enable pdo pdo )
-       $(use_enable opcache opcache )
-       $(use_with postgres pgsql "${EPREFIX}"/usr)
+       $(use_enable phar phar )
        $(use_enable posix posix )
-       $(use_with spell pspell "${EPREFIX}"/usr)
-       $(use_with recode recode "${EPREFIX}"/usr)
-       $(use_enable simplexml simplexml )
+       $(use_with   postgres pgsql "${EPREFIX}"/usr)
+       $(use_with   spell pspell "${EPREFIX}"/usr)
+       $(use_with   recode recode "${EPREFIX}"/usr)
        $(use_enable sharedmem shmop )
-       $(use_with snmp snmp "${EPREFIX}"/usr)
+       $(use_enable simplexml simplexml )
+       $(use_with   snmp snmp "${EPREFIX}"/usr)
        $(use_enable soap soap )
        $(use_enable sockets sockets )
-       $(use_with sqlite sqlite3 "${EPREFIX}"/usr)
-       $(use_with sybase-ct sybase-ct "${EPREFIX}"/usr)
+       $(use_with   sqlite sqlite3 "${EPREFIX}"/usr)
+       $(use_with   ssl openssl "${EPREFIX}"/usr)
+       $(use_with   ssl openssl-dir "${EPREFIX}"/usr)
+       $(use_with   sybase-ct sybase-ct "${EPREFIX}"/usr)
+       $(use_with   systemd fpm-systemd)
        $(use_enable sysvipc sysvmsg )
        $(use_enable sysvipc sysvsem )
        $(use_enable sysvipc sysvshm )
-       $(use_with systemd fpm-systemd)
-       $(use_with tidy tidy "${EPREFIX}"/usr)
+       $(use_with   tidy tidy "${EPREFIX}"/usr)
        $(use_enable tokenizer tokenizer )
+       $(use_enable unicode mbstring )
+       $(use_with   unicode onig "${EPREFIX}"/usr)
        $(use_enable wddx wddx )
+       $(use_enable xml dom )
+       $(use_enable xml libxml )
+       $(use_with   xml libxml-dir "${EPREFIX}"/usr)
        $(use_enable xml xml )
        $(use_enable xmlreader xmlreader )
+       $(use_with   xmlrpc xmlrpc)
        $(use_enable xmlwriter xmlwriter )
-       $(use_with xmlrpc xmlrpc)
-       $(use_with xslt xsl "${EPREFIX}"/usr)
+       $(use_with   xslt xsl "${EPREFIX}"/usr)
        $(use_enable zip zip )
-       $(use_with zlib zlib "${EPREFIX}"/usr)
-       $(use_enable debug debug )"
+       $(use_with   zlib zlib "${EPREFIX}"/usr)"
 
        # DBA support
        if use cdb || use berkdb || use flatfile || use gdbm || use inifile \
@@ -435,13 +439,6 @@ src_configure() {
                $(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
-       # Interbase/firebird support
-
-       if use firebird ; then
-               my_conf+="
-               $(use_with firebird interbase ${EPREFIX}/usr)"
-       fi
-
        # LDAP support
        if use ldap ; then
                my_conf+="
@@ -465,23 +462,6 @@ src_configure() {
                my_conf+="${mysqlsock}"
        fi
 
-       # ODBC support
-       if use odbc ; then
-               my_conf+="
-               $(use_with odbc unixODBC ${EPREFIX}/usr)"
-       fi
-
-       if use iodbc ; then
-               my_conf+="
-               $(use_with iodbc iodbc ${EPREFIX}/usr)"
-       fi
-
-       # Oracle support
-       if use oci8-instant-client ; then
-               my_conf+="
-               $(use_with oci8-instant-client oci8)"
-       fi
-
        # PDO support
        if use pdo ; then
                my_conf+="