]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - dev-lang/php/php-5.6.4-r1.ebuild
Remove redundant "if use ldap" check.
[mjo-overlay.git] / dev-lang / php / php-5.6.4-r1.ebuild
index 79be81f97897977f85ac5da95f6671ae1db0f4aa..371a080e99cd06b1290e4a48b81bc5c3427b69b3 100644 (file)
@@ -352,18 +352,23 @@ src_configure() {
        $(use_enable exif exif )
        $(use_enable fileinfo fileinfo )
        $(use_enable filter filter )
+       $(use_with   firebird interbase "${EPREFIX}"/usr)
        $(use_enable ftp ftp )
        $(use_with   gmp gmp "${EPREFIX}"/usr)
        $(use_enable hash hash )
        $(use_with   iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
+       $(use_with   imap imap "${EPREFIX}"/usr)
        $(use_enable intl intl )
        $(use_with   iodbc iodbc "${EPREFIX}"/usr)
        $(use_enable ipv6 ipv6 )
        $(use_enable json json )
        $(use_with   kerberos kerberos "${EPREFIX}"/usr)
+       $(use_with   ldap ldap "${EPREFIX}"/usr)
+       $(use_with   ldap-sasl ldap-sasl "${EPREFIX}"/usr)
        $(use_with   mhash mhash "${EPREFIX}"/usr)
        $(use_with   mssql mssql "${EPREFIX}"/usr)
        $(use_with   nls gettext "${EPREFIX}"/usr)
+       $(use_with   oci8-instant-client oci8)
        $(use_with   odbc unixODBC "${EPREFIX}"/usr)
        $(use_enable opcache opcache )
        $(use_enable pcntl pcntl )
@@ -430,25 +435,9 @@ src_configure() {
        my_conf+="
        $(use_with gd gd)"
 
-       # IMAP support
+       # IMAP SSL support
        if use imap ; then
-               my_conf+="
-               $(use_with imap imap ${EPREFIX}/usr)
-               $(use_with ssl imap-ssl ${EPREFIX}/usr)"
-       fi
-
-       # Interbase/firebird support
-
-       if use firebird ; then
-               my_conf+="
-               $(use_with firebird interbase ${EPREFIX}/usr)"
-       fi
-
-       # LDAP support
-       if use ldap ; then
-               my_conf+="
-               $(use_with ldap ldap ${EPREFIX}/usr)
-               $(use_with ldap-sasl ldap-sasl ${EPREFIX}/usr)"
+               my_conf+="$(use_with ssl imap-ssl ${EPREFIX}/usr)"
        fi
 
        # MySQL support
@@ -467,12 +456,6 @@ src_configure() {
                my_conf+="${mysqlsock}"
        fi
 
-       # Oracle support
-       if use oci8-instant-client ; then
-               my_conf+="
-               $(use_with oci8-instant-client oci8)"
-       fi
-
        # PDO support
        if use pdo ; then
                my_conf+="