]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-text/XML-Schema-learner/XML-Schema-learner-9999.ebuild
app-text/XML-Schema-learner: Add a longdescription and remove unneeded stuff from...
[mjo-overlay.git] / app-text / XML-Schema-learner / XML-Schema-learner-9999.ebuild
index 4313850cde1513d5e21281d58c4db1bf4ecedec1..6330e74bdb369a42fb76c3e279681d62e4b1ebf6 100644 (file)
@@ -4,11 +4,11 @@
 
 EAPI=5
 
+EGIT_REPO_URI="https://github.com/mjorlitzky/${PN}.git"
+inherit git-2
+
 DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
-# See also:
-# http://kore-nordmann.de/blog/0104_generating_xml_schemas_from_xml.html
 HOMEPAGE="https://github.com/kore/XML-Schema-learner"
-SRC_URI=""
 
 LICENSE="GPL-3"
 SLOT="0"
@@ -18,7 +18,11 @@ IUSE="test"
 DEPEND="test? ( dev-php/phpunit )"
 RDEPEND="dev-lang/php[cli,xml,xmlreader]"
 
-src_test {
-       cd "${S}"
-       phpunit tests/suite.php || die 'test suite (suite.php) failed'
+src_compile() {
+       # Don't run make, the default target is 'check'.
+       :
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="/usr" install
 }