]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-text/XML-Schema-learner/XML-Schema-learner-9999.ebuild
Get XML-Schema-learner working.
[mjo-overlay.git] / app-text / XML-Schema-learner / XML-Schema-learner-9999.ebuild
index 4313850cde1513d5e21281d58c4db1bf4ecedec1..42436eeb1bea1189934d12408ec69146769c9f93 100644 (file)
@@ -4,11 +4,14 @@
 
 EAPI=5
 
+EGIT_REPO_URI="https://github.com/mjorlitzky/${PN}.git"
+inherit git-2
+
 DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
 # See also:
 # http://kore-nordmann.de/blog/0104_generating_xml_schemas_from_xml.html
 HOMEPAGE="https://github.com/kore/XML-Schema-learner"
-SRC_URI=""
+#SRC_URI=""
 
 LICENSE="GPL-3"
 SLOT="0"
@@ -18,7 +21,11 @@ IUSE="test"
 DEPEND="test? ( dev-php/phpunit )"
 RDEPEND="dev-lang/php[cli,xml,xmlreader]"
 
-src_test {
-       cd "${S}"
-       phpunit tests/suite.php || die 'test suite (suite.php) failed'
+src_compile() {
+       # Don't run make, the default target is 'check'.
+       :
+}
+
+src_install() {
+       emake DESTDIR="${D}" PREFIX="/usr" install
 }