]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-laptop/hdapsd/hdapsd-20141024.ebuild
app-laptop/hdapsd: always print elog message.
[mjo-overlay.git] / app-laptop / hdapsd / hdapsd-20141024.ebuild
index a4e29e02d7c6318e3cae00ca4030e8b79716c0ea..e8d6dc32a0bfe3d0521876ccb4723af8eaee40a2 100644 (file)
@@ -18,17 +18,14 @@ DEPEND="libconfig? ( dev-libs/libconfig )"
 RDEPEND="${DEPEND}"
 
 pkg_setup() {
-       # We require the hdaps module which can either come from kernel sources
-       # or from the tp_smapi package.
+       # We require the hdaps module which can either come from either the
+       # kernel itself (CONFIG_SENSORS_HDAPS) or from the tp_smapi package.
        if ! has_version app-laptop/tp_smapi[hdaps]; then
                CONFIG_CHECK="~SENSORS_HDAPS"
-               ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi (with hdaps USE enabled) or support for CONFIG_SENSORS_HDAPS enabled"
+               ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi[hdaps] or "
+               ERROR_SENSORS_HDAPS+="kernel support for CONFIG_SENSORS_HDAPS enabled"
                linux-info_pkg_setup
        fi
-
-       DOC_CONTENTS="You can change the default frequency by modifing /sys/devices/platform/hdaps/sampling_rate.
-               You might need to enable shock protection manually by running:\n
-               # echo -1 > /sys/block/DEVICE/device/unload_heads"
 }
 
 src_configure(){
@@ -40,8 +37,8 @@ src_configure(){
 
 src_install() {
        default
-       newconfd "${FILESDIR}"/hdapsd.conf.3 hdapsd
-       newinitd "${FILESDIR}"/hdapsd.init.3 hdapsd
+       newconfd "${FILESDIR}/hdapsd.conf-${PV}" hdapsd
+       newinitd "${FILESDIR}/hdapsd.init-${PV}" hdapsd
        readme.gentoo_create_doc
 }
 
@@ -50,10 +47,28 @@ pkg_postinst(){
        [[ -z $(ls "${EROOT}"sys/block/*/device/unload_heads 2>/dev/null) ]] && \
                ewarn "Your kernel does NOT support shock protection."
 
-       if ! has_version app-laptop/tp_smapi[hdaps]; then
-               ewarn "Using the hdaps module provided by app-laptop/tp_smapi instead"
-               ewarn "of the in-kernel driver is strongly recommended!"
-       fi
-
        readme.gentoo_print_elog
 }
+
+DISABLE_AUTOFORMATTING=1
+FORCE_PRINT_ELOG=1
+DOC_CONTENTS="
+${PN} requires a kernel module to function properly. The recommended
+approach is to install app-laptop/tp_smapi[hdaps], but the in-tree
+module provided by CONFIG_SENSORS_HDAPS may work as well.
+
+Common daemon parameters can be set in ${EROOT}etc/conf.d/${PN}. If the
+package was installed with USE=libconfig, then the parameters can also
+be set in ${EROOT}etc/${PN}.conf, although the former will take
+precedence over the latter if both are used.
+
+You can change the default sampling rate by modifing
+
+  /sys/devices/platform/hdaps/sampling_rate
+
+and you may need to enable shock protection manually by running
+
+  # echo -1 > /sys/block/<disk>/device/unload_heads
+
+as root.
+"