]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-laptop/hdapsd/hdapsd-20141024.ebuild
Use versioned init/conf files and clean up the ebuild a little.
[mjo-overlay.git] / app-laptop / hdapsd / hdapsd-20141024.ebuild
index a4e29e02d7c6318e3cae00ca4030e8b79716c0ea..d3af8e82a4d1c1eac748ccc204ab8a5cc5c7c8ab 100644 (file)
@@ -22,13 +22,11 @@ pkg_setup() {
        # or from the tp_smapi package.
        if ! has_version app-laptop/tp_smapi[hdaps]; then
                CONFIG_CHECK="~SENSORS_HDAPS"
-               ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi (with hdaps USE enabled) or support for CONFIG_SENSORS_HDAPS enabled"
+               ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi (with hdaps "
+               ERROR_SENSORS_HDAPS+="USE enabled) or kernel support for "
+               ERROR_SENSORS_HDAPS+="CONFIG_SENSORS_HDAPS enabled"
                linux-info_pkg_setup
        fi
-
-       DOC_CONTENTS="You can change the default frequency by modifing /sys/devices/platform/hdaps/sampling_rate.
-               You might need to enable shock protection manually by running:\n
-               # echo -1 > /sys/block/DEVICE/device/unload_heads"
 }
 
 src_configure(){
@@ -40,8 +38,8 @@ src_configure(){
 
 src_install() {
        default
-       newconfd "${FILESDIR}"/hdapsd.conf.3 hdapsd
-       newinitd "${FILESDIR}"/hdapsd.init.3 hdapsd
+       newconfd "${FILESDIR}/hdapsd.conf-${PV}" hdapsd
+       newinitd "${FILESDIR}/hdapsd.init-${PV}" hdapsd
        readme.gentoo_create_doc
 }
 
@@ -57,3 +55,16 @@ pkg_postinst(){
 
        readme.gentoo_print_elog
 }
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS='
+You can change the default frequency by modifing,
+
+       /sys/devices/platform/hdaps/sampling_rate
+
+You might need to enable shock protection manually by running:
+
+       # echo -1 > /sys/block/DEVICE/device/unload_heads
+
+as root.
+'