]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-laptop/hdapsd/hdapsd-20141024.ebuild
app-laptop/hdapsd: more doc cleanup
[mjo-overlay.git] / app-laptop / hdapsd / hdapsd-20141024.ebuild
index d3af8e82a4d1c1eac748ccc204ab8a5cc5c7c8ab..bbe969dcf316565f7ec7aad69209ca00380a123a 100644 (file)
@@ -18,13 +18,12 @@ DEPEND="libconfig? ( dev-libs/libconfig )"
 RDEPEND="${DEPEND}"
 
 pkg_setup() {
-       # We require the hdaps module which can either come from kernel sources
-       # or from the tp_smapi package.
+       # We require the hdaps module which can either come from either the
+       # kernel itself (CONFIG_SENSORS_HDAPS) or from the tp_smapi package.
        if ! has_version app-laptop/tp_smapi[hdaps]; then
                CONFIG_CHECK="~SENSORS_HDAPS"
-               ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi (with hdaps "
-               ERROR_SENSORS_HDAPS+="USE enabled) or kernel support for "
-               ERROR_SENSORS_HDAPS+="CONFIG_SENSORS_HDAPS enabled"
+               ERROR_SENSORS_HDAPS="${P} requires app-laptop/tp_smapi[hdaps] or "
+               ERROR_SENSORS_HDAPS+="kernel support for CONFIG_SENSORS_HDAPS enabled"
                linux-info_pkg_setup
        fi
 }
@@ -48,23 +47,27 @@ pkg_postinst(){
        [[ -z $(ls "${EROOT}"sys/block/*/device/unload_heads 2>/dev/null) ]] && \
                ewarn "Your kernel does NOT support shock protection."
 
-       if ! has_version app-laptop/tp_smapi[hdaps]; then
-               ewarn "Using the hdaps module provided by app-laptop/tp_smapi instead"
-               ewarn "of the in-kernel driver is strongly recommended!"
-       fi
-
        readme.gentoo_print_elog
 }
 
 DISABLE_AUTOFORMATTING=1
-DOC_CONTENTS='
-You can change the default frequency by modifing,
+DOC_CONTENTS="
+${PN} requires a kernel module to function properly. The recommended
+approach is to install app-laptop/tp_smapi[hdaps], but the in-tree
+module provided by CONFIG_SENSORS_HDAPS may work as well.
+
+Common daemon parameters can be set in ${EROOT}etc/conf.d/${PN}. If the
+package was installed with USE=libconfig, then the parameters can also
+be set in ${EROOT}etc/${PN}.conf, although the former will take
+precedence over the latter if both are used.
+
+You can change the default sampling rate by modifing
 
        /sys/devices/platform/hdaps/sampling_rate
 
-You might need to enable shock protection manually by running:
+and you may need to enable shock protection manually by running
 
-       # echo -1 > /sys/block/DEVICE/device/unload_heads
+       # echo -1 > /sys/block/<disk>/device/unload_heads
 
 as root.
-'
+"