]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - app-admin/eselect-postgresql/eselect-postgresql-1.2.1.ebuild
Remove sys-process/xjobs for inclusion in gentoo-x86.
[mjo-overlay.git] / app-admin / eselect-postgresql / eselect-postgresql-1.2.1.ebuild
index 4a437415a5241459202fd99dcdc0c64f8a4782fe..abc5d8bc32e4d5af495e72bcfecc9f03b71142d8 100644 (file)
@@ -4,6 +4,8 @@
 
 EAPI="5"
 
+inherit multilib
+
 DESCRIPTION="Utility to select the default PostgreSQL slot"
 HOMEPAGE="http://www.gentoo.org/"
 SRC_URI="http://dev.gentoo.org/~titanofold/${P}.tbz2"
@@ -21,6 +23,14 @@ src_install() {
        doins postgresql.eselect
 
        dosym /usr/bin/eselect /usr/bin/postgresql-config
+
+       # Create an env.d file that will append the currently-selected
+       # Postgres's pkgconfig path to the PKG_CONFIG_PATH environment
+       # variable. See bug #512236.
+       local pcp="${EPREFIX}/usr/$(get_libdir)/postgresql/pkgconfig"
+       echo "PKG_CONFIG_PATH=\"${pcp}\"" > "${T}"/99postgresql
+
+       doenvd "${T}"/99postgresql
 }
 
 pkg_postinst() {