]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - www-apache/mod_vhost_ldap/mod_vhost_ldap-2.4.0.ebuild
705814d2ffe27f67aa97642ea1a99e778cfb1870
[mjo-overlay.git] / www-apache / mod_vhost_ldap / mod_vhost_ldap-2.4.0.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit eutils apache-module
8
9 DESCRIPTION="Store and configure Apache virtual hosts using LDAP"
10 HOMEPAGE="http://modvhostldap.alioth.debian.org/"
11 SRC_URI="http://dev.gentoo.org/~mjo/distfiles/${P}.tar.xz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 APACHE2_MOD_CONF="99_${PN}"
19 APACHE2_MOD_DEFINE="VHOST_LDAP LDAP"
20
21 DOCFILES="AUTHORS ChangeLog INSTALL README"
22
23 # apache[ldap] is needed to run, but not to compile.
24 DEPEND=""
25 RDEPEND="=www-servers/apache-2*[ldap]"
26
27 need_apache2
28
29 src_prepare() {
30 sed -i "s/MOD_VHOST_LDAP_VERSION/\"${PV}\"/g" "${PN}.c"
31 }
32
33 src_install() {
34 apache-module_src_install
35 insinto /etc/openldap/schema
36 doins mod_vhost_ldap.schema
37 }
38
39 pkg_postinst() {
40 apache-module_pkg_postinst
41 einfo
42 einfo "Your LDAP server needs to include mod_vhost_ldap.schema and should"
43 einfo "also maintain indices on apacheServerName and apacheServerAlias."
44 einfo
45 }