]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - www-apache/mod_ldap_userdir/mod_ldap_userdir-1.1.19.ebuild
1a380787c78a9caaf736cc0a92e1694d77251445
[mjo-overlay.git] / www-apache / mod_ldap_userdir / mod_ldap_userdir-1.1.19.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit apache-module
8
9 DESCRIPTION="Look up Apache ~user directories in an LDAP directory"
10 HOMEPAGE="http://horde.net/~jwm/software/${PN}/"
11 SRC_URI="http://horde.net/~jwm/software/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE="ssl"
17
18 # The module will compile fine without apache[ldap], but Apache will
19 # crash if you try to load the module before rebuilding Apache with LDAP
20 # support (and enabling it!).
21 DEPEND="net-nds/openldap
22 www-servers/apache
23 ssl? ( dev-libs/openssl )"
24 RDEPEND="${DEPEND}
25 www-servers/apache[ldap]"
26
27 APACHE2_MOD_CONF="47_${PN}"
28 APACHE2_MOD_DEFINE="LDAP LDAP_USERDIR"
29
30 DOCFILES="DIRECTIVES README user-ldif"