]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - sys-fs/e4rat/e4rat-0.1.5.ebuild
8ca63a83d9fba13d1f611685bd9f2d84068fccb0
[mjo-overlay.git] / sys-fs / e4rat / e4rat-0.1.5.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit cmake-utils flag-o-matic
6
7 DESCRIPTION="Toolset to accelerate the boot process and application startup"
8 HOMEPAGE="http://e4rat.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-lang/perl
17 >=dev-libs/boost-1.41
18 sys-fs/e2fsprogs
19 sys-process/audit"
20
21 RDEPEND="${DEPEND}"
22
23 CMAKE_IN_SOURCE_BUILD=1
24 PATCHES=( "${FILESDIR}/cmake_mkdir_violation_fix.patch" )
25
26 src_compile() {
27 filter-ldflags "-Wl,--as-needed"
28 cmake-utils_src_compile
29 }
30
31 pkg_preinst() {
32 dodir /var/lib/e4rat
33 }