]> gitweb.michael.orlitzky.com - mjo-overlay.git/blob - app-text/XML-Schema-learner/XML-Schema-learner-9999.ebuild
4313850cde1513d5e21281d58c4db1bf4ecedec1
[mjo-overlay.git] / app-text / XML-Schema-learner / XML-Schema-learner-9999.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 DESCRIPTION="Algorithmic inferencing of XML schema definitions and DTDs"
8 # See also:
9 # http://kore-nordmann.de/blog/0104_generating_xml_schemas_from_xml.html
10 HOMEPAGE="https://github.com/kore/XML-Schema-learner"
11 SRC_URI=""
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="test"
17
18 DEPEND="test? ( dev-php/phpunit )"
19 RDEPEND="dev-lang/php[cli,xml,xmlreader]"
20
21 src_test {
22 cd "${S}"
23 phpunit tests/suite.php || die 'test suite (suite.php) failed'
24 }