]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild
Add the libexecdir fix posted by Samuli.
[mjo-overlay.git] / xfce-extra / xfce4-hdaps / xfce4-hdaps-0.0.7.ebuild
index c6c65488077b9d45a6077820bd3fb08ec2ae99ea..6ac70b6541a52b08debf90d623e8326f80ac145c 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.6.ebuild,v 1.3 2010/12/18 19:42:21 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-hdaps/xfce4-hdaps-0.0.7.ebuild,v 1.4 2011/05/20 11:21:23 tomka Exp $
 
-EAPI=3
+EAPI=4
 inherit linux-info xfconf
 
 DESCRIPTION="A plugin to indicate the status of the IBM Hard Drive Active Protection System"
@@ -11,13 +11,13 @@ SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
 
 LICENSE="GPL-3"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="debug"
 
 COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
-       >=xfce-base/libxfce4ui-4.7
-       >=xfce-base/libxfce4util-4.6
-       >=xfce-base/xfce4-panel-4.6"
+       >=xfce-base/libxfce4ui-4.8
+       >=xfce-base/libxfce4util-4.8
+       >=xfce-base/xfce4-panel-4.8"
 RDEPEND="${COMMON_DEPEND}
        >=app-laptop/hdapsd-20081213
        >=app-laptop/tp_smapi-0.39"
@@ -29,16 +29,17 @@ DEPEND="${COMMON_DEPEND}
 pkg_setup() {
        XFCONF=(
                --disable-option-checking
+               --libexecdir="${EPREFIX}"/usr/$(get_libdir)
                $(xfconf_use_debug)
                )
 
-       DOCS="AUTHORS ChangeLog NEWS README TODO"
+       DOCS=( AUTHORS ChangeLog NEWS README TODO )
 
        linux-info_pkg_setup
 
        if kernel_is lt 2 6 28; then
-               ewarn
+               echo
                ewarn "Unsupported kernel detected. Upgrade to 2.6.28 or above."
-               ewarn
+               echo
        fi
 }