]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sys-fs/e4rat/e4rat-0.2.ebuild
Version bump to v0.2, still needs the --as-needed fix.
[mjo-overlay.git] / sys-fs / e4rat / e4rat-0.2.ebuild
diff --git a/sys-fs/e4rat/e4rat-0.2.ebuild b/sys-fs/e4rat/e4rat-0.2.ebuild
new file mode 100644 (file)
index 0000000..e8bc051
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cmake-utils
+
+DESCRIPTION="Toolset to accelerate the boot process and application startup"
+HOMEPAGE="http://e4rat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P/-/_}_src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+       >=dev-libs/boost-1.41
+       sys-fs/e2fsprogs
+       sys-process/audit"
+
+RDEPEND="${DEPEND}"
+
+CMAKE_BUILD_TYPE=release
+CMAKE_IN_SOURCE_BUILD=1
+PATCHES=( "${FILESDIR}/cmake_mkdir_violation_fix.patch"
+       "${FILESDIR}/v0.2_as-needed_fix.patch" )
+
+pkg_preinst() {
+       dodir /var/lib/e4rat
+}