]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - sys-fs/e4rat/e4rat-0.1.5.ebuild
Add an ebuild for e4rat.
[mjo-overlay.git] / sys-fs / e4rat / e4rat-0.1.5.ebuild
diff --git a/sys-fs/e4rat/e4rat-0.1.5.ebuild b/sys-fs/e4rat/e4rat-0.1.5.ebuild
new file mode 100644 (file)
index 0000000..de2817e
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit cmake-utils flag-o-matic
+
+DESCRIPTION="Toolset to accelerate the boot process and application startup"
+HOMEPAGE="http://e4rat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+       >=dev-libs/boost-1.41
+       sys-fs/e2fsprogs
+       sys-process/audit"
+
+RDEPEND="${DEPEND}"
+
+CMAKE_IN_SOURCE_BUILD=1
+PATCHES="${FILESDIR}/cmake_mkdir_violation_fix.patch"
+
+src_compile() {
+       filter-ldflags "-Wl,--as-needed"
+       cmake-utils_src_compile
+}
+
+pkg_preinst() {
+       dodir /var/lib/e4rat
+}