]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-libs/rb_libtorrent/rb_libtorrent-9999.ebuild
Add rb_libtorrent-9999.
[mjo-overlay.git] / net-libs / rb_libtorrent / rb_libtorrent-9999.ebuild
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-9999.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-9999.ebuild
new file mode 100644 (file)
index 0000000..0c517a3
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.6.ebuild,v 1.5 2011/05/26 21:21:00 maekke Exp $
+
+EAPI="2"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+
+inherit eutils versionator python subversion
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+ESVN_REPO_URI="https://libtorrent.svn.sourceforge.net/svnroot/libtorrent/trunk"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples python ssl"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.36[python?]
+       >=sys-devel/libtool-2.2
+       sys-libs/zlib
+       examples? ( !net-p2p/mldonkey )
+       ssl? ( dev-libs/openssl )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+       use python && python_set_active_version 2
+}
+
+src_prepare() {
+       use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+       ./autotool.sh
+
+       # use multi-threading versions of boost libs
+       local BOOST_LIBS="--with-boost-system=boost_system-mt \
+               --with-boost-filesystem=boost_filesystem-mt \
+               --with-boost-thread=boost_thread-mt \
+               --with-boost-python=boost_python-mt"
+       # detect boost version and location, bug 295474
+       BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+       BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+       BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+       BOOST_INC="/usr/include/boost-${BOOST_VER}"
+       BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
+
+       local LOGGING
+       use debug && LOGGING="--enable-logging=verbose"
+
+       econf $(use_enable debug) \
+               $(use_enable test tests) \
+               $(use_enable examples) \
+               $(use_enable python python-binding) \
+               $(use_enable ssl encryption) \
+               --with-zlib=system \
+               ${LOGGING} \
+               --with-boost=${BOOST_INC} \
+               --with-boost-libdir=${BOOST_LIB} \
+               ${BOOST_LIBS}
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die 'emake install failed'
+       dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
+       if use doc ; then
+               dohtml docs/* || die "Could not install HTML documentation"
+       fi
+}