]> gitweb.michael.orlitzky.com - mjo-overlay.git/blobdiff - net-dns/djbdns/djbdns-1.05-r24.ebuild
Fix the patch URL in the elog output.
[mjo-overlay.git] / net-dns / djbdns / djbdns-1.05-r24.ebuild
index 31d1589c3193146624ff2a3748cf794ea174a375..715edbc289450cc27bdb4a45ef6bf7e5b7e9ffd9 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.1 2011/04/04 14:05:00 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/djbdns/djbdns-1.05-r24.ebuild,v 1.5 2012/03/24 09:26:18 hwoarang Exp $
 
 EAPI="2"
 inherit eutils flag-o-matic toolchain-funcs
@@ -27,12 +27,13 @@ RDEPEND="${DEPEND}
 
 src_prepare() {
        echo
-       elog 'Several patches have been dropped from this djbdns ebuild revision.'
-       elog 'Please use the DJBDNS_PATCH_DIR variable to specify a directory'
-       elog 'of custom patches.'
+       elog 'Several patches have been dropped from this ebuild.'
+       elog 'Please place custom patches in,'
+       elog
+       elog '  /etc/portage/patches/net-dns/djbdns'
        elog
        elog 'Some of them can be found at http://tinydns.org/ or'
-       elog 'http://homepages.tesco.net/J.deBoynePollard/Softwares/djbdns/'
+       elog 'http://homepage.ntlworld.com/jonathan.deboynepollard/Softwares/djbdns/'
        elog
 
        epatch \
@@ -46,7 +47,7 @@ src_prepare() {
 
        if use ipv6; then
                elog "At present dnstrace does NOT support IPv6. It will"\
-                    "be compiled without IPv6 support."
+                        "be compiled without IPv6 support."
                cp -pR "${S}" "${S}-noipv6"
                # Careful -- >=test21 of the IPv6 patch includes the errno patch
                epatch "${DISTDIR}/${P}-${IPV6_PATCH}.diff.bz2"
@@ -54,7 +55,8 @@ src_prepare() {
                # Fix CVE2008-4392
                epatch \
                        "${FILESDIR}/CVE2008-4392_0001-dnscache-merge-similar-outgoing-queries-ipv6.patch" \
-                       "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch"
+                       "${FILESDIR}/CVE2008-4392_0002-dnscache-cache-soa-records-ipv6.patch" \
+                       "${FILESDIR}/makefile-parallel.patch"
 
                cd "${S}-noipv6"
        fi
@@ -66,16 +68,8 @@ src_prepare() {
 
        epatch "${FILESDIR}/${PV}-errno.patch"
 
-       if [[ -n "${DJBDNS_PATCH_DIR}" && -d "${DJBDNS_PATCH_DIR}" ]]
-       then
-               echo
-               ewarn "You enabled custom patches from ${DJBDNS_PATCH_DIR}."
-               ewarn "Be warned that you won't get any support when using "
-               ewarn "this feature. You're on your own from now!"
-               echo
-               ebeep
-               cd "${S}" && epatch "${DJBDNS_PATCH_DIR}/"*
-       fi
+       cd "${S}"
+       epatch_user
 }
 
 src_compile() {
@@ -83,7 +77,8 @@ src_compile() {
        echo "$(tc-getCC) ${CFLAGS}" > conf-cc
        echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
        echo "/usr" > conf-home
-       emake -j1 || die "emake failed"
+       #emake -j1 || die "emake failed"
+       emake || die "emake failed"
 
        # If djbdns is compiled with IPv6 support, it breaks dnstrace.
        # Therefore we must compile dnstrace separately without IPv6
@@ -94,7 +89,8 @@ src_compile() {
                echo "$(tc-getCC) ${CFLAGS}" > conf-cc
                echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
                echo "/usr" > conf-home
-               emake -j1 dnstrace || die "emake failed"
+               #emake -j1 dnstrace || die "emake failed"
+               emake dnstrace || die "emake failed"
        fi
 }
 
@@ -115,10 +111,10 @@ src_install() {
 
        dobin "${FILESDIR}/dnscache-setup" || die
        dobin "${FILESDIR}/tinydns-setup" || die
-       newbin "${FILESDIR}/djbdns-setup-r17" djbdns-setup || die
+       dobin "${FILESDIR}/djbdns-setup" || die
 }
 
-pkg_setup() {
+pkg_preinst() {
        # The nofiles group is provided by baselayout
        enewuser dnscache -1 -1 -1 nofiles
        enewuser dnslog -1 -1 -1 nofiles